Great Plains Consultant News: upgrade to version 10.0 issues

By: Andrew Karasev

If you are planning to upgrade from earlier version, you should read the upgrade recommendations on your GP customer or partner source.? In some cases you may get original news and work around from consultants in the field, who are doing upgrade on the daily base.? We would like to give you the most popular upgrade highlights:

1.?????? Service pack sensitivity.? If you have GP 10.0 CD #1 and 2, it doesn’t mean that you just insert it and follow upgrade wizard.? It used to be like that with previous version, however update to 10.0 is sensitive to Service Packs applied. ?The best recommendation is this – install initial GP 10.0 version from CD, then, prior to launching GP Utilities, apply latest service pack, available for version 10.0.

2.?????? Mekorma Safe Pay tables merge and upgrade issues.? Of course this is our unofficial opinion, however we saw it at this time twice in upgrade.? You get error messages about these tables: SY06000 and CM00101.? Both tables are new and in essence are replacement for abolished former Mekorma product tables.? The error is strange and at this time it is not logged in GP knowledge base: you should remove temporary table.? We tried the following work around.? Try to reload sample company TWO, then login to Sample company (Fabrikam), open maintenance->SQL, then in each company database drop and recreate these tables and atomic stored procedures.? This news might be short living, however for us it was really the pain and trouble

3.?????? GP 10.0 Workstation and .Net Framework version.? If you are on .Net framework 2.0 SP1 or 3.5, then you will need to uninstall these and then reload .Net framework 2.0 (without service pack) either from Microsoft Download Center or From GP CD #1.? If you are loading GP 10.0 WS on Windows 2003 server 64 bit edition, you should read Knowledge Base on how to make registry changes to allow you GP workstation installation

4.?????? FRx.? It seems to work as is, however you can follow additional FRx Service Pack installation instructions, or make it part of GP version update phase two

5.?????? Integration Manager.? In GP 10.0 you will see new connectors on the eConnect base.? Plus GP IM default integration database is now not pure Microsoft Access file

Hardware
 • 
 • 
 • 
 • 
 • 
 • 
 • 
 • 
 • 
 • 
 • 
 • 
 • 
 • 
 • 
 • 
 • 
 • 
 • 
 • 

» More on Hardware