Moisture and Cable Problems with your Phone

by : vgevge



It seems to me that the cable between the flip seems to be going bad. Opening it up and looking for cracks in the cable may help but ultimately you would have to replace the cable. That's why motorola wants to charge you that amount of money. Repairs are expensive.

However the thing that seems to be shocking me is that you are still getting sound so that means that your phone didn't crash. One thing comes to mind for you to try before you send it to Motorola, and that is to re-flash the phone with a new flex version and see if that helps.

But that is very risky and you shouldn't attempt it unless you are sure that you now exactly what it is that you are doing.

Providing the phone hasn't been dropped on hard surfaces numerous times, I really can't think of any other reason why it should stop working, besides the fact the water indicator has turned red.
It seems to me the phone has been subjected to an excessive amount of moisture. Had the water been minimal, you wouldn't be able to see the red dot, and the phone would've be working fine. There isn't anything you can do in terms of button pressing, as it'll just give you the same result; blank white screen. It appears the internal connections have been affected, and considering you don't mind opening up your phone, you should go ahead. What you're looking for is soiled/corroded/dark area's on the phone's chip. If you do spot such things, excessive water has past through the unit, and I'd advise you to fork out that $75 or perhaps invest in a new phone. If everything seems fine within the phone, just check the wiring anyway. It's highly unlikely the wires would be disconnected/loose connection, and if it did, I can only assume its taken several hard knocks to get like that, perhaps beyond what the phone can handle.

It does sound like water or moisture may have gotten into the phone. Unfortunately, when that happens, as it sounds like you already know, that invalidates any warranties. Issues with the dreaded white screen on several of the models like the 505 and oftentimes, a firmware update will solve the problem. I would suggest checking with your wireless provider and seeing if there is a firmware update. I agree that $75 is too high a price to get it fixed. If you decide to fix it yourself, you could make it worse. I don't believe that the white screen indictes a loose connection or unattached connection.